How To Install Gigapixel AI As A Photoshop Plugin

If you are an Adobe Photoshop user using Photoshop 2017 or newer, Gigapixel AI should automatically install into Photoshop as a plugin under File > Automate. This article explains various ways to install the Adobe Photoshop plugin for Gigapixel AI if needed.

Instructions For Other Host Programs
Photoshop CS6 Plugin Installation
Lightroom Plugin Installation
Photoshop Elements Plugin Installation


How to Install Gigapixel AI As A Photoshop Plugin

Gigapixel AI's Photoshop plugin should automatically install to Photoshop's Filter menu on compatible Mac and Windows devices. If it doesn't, the following instructions may be applicable to different users:

Special Notes About M1/Apple Silicon Devices
Manually Install Gigapixel AI As A Photoshop Plugin On Mac
Manually Install Gigapixel AI As A Photoshop Plugin On Windows

NOTE
- The Gigapixel AI plugin does not show up under Filter like other Topaz Labs Photoshop plugins. Before following these instructions, please check the File > Automate menu first.
- The Gigapixel AI Photoshop plugins only work on Photoshop CC 2017 and above. Other Topaz apps work in Photoshop CC 2015 and above.
- There is no "Reinstall Photoshop Plugins" in the Help menu of Gigapixel AI as can be found in some other programs.


Special Notes About M1/Apple Silicon Devices

NOTE
The current Gigapixel plugin is NOT M1 native. You will need to run Photoshop in Rosetta to use this plugin with M1 native Photoshop. The plugin will not appear until you do so even if it has been installed correctly. You can automatically run Photoshop through Rosetta by going to the "Get Info" section when right-clicking on the Photoshop Icon and selecting the "Run With Rosetta" checkbox.


Manually Install Gigapixel AI As A Photoshop Plugin On Mac


Step 1:

Close Photoshop

Step 2:

Navigate to the Topaz Gigapixel AI application under Applications/Topaz Labs LLC

Step 3

Right click and select "Show Package Contents."

Step 4

Navigate to the "Resources" folder.

Step 5

Right click the PS_Plugins folder and select "Make Alias".

Step 6:

Rename the new alias to TopazGigapixelAI.

Step 7

Right click and copy the TopazGigapixelAI alias.

Step 8

Navigate to the appropriate Adobe plug-ins folder for your installation and paste the alias into the folder.

Depending on your Photoshop installation, the appropriate folder may be:

Photoshop CC: /Library/Application Support/Adobe/Plug-Ins/CC.
Photoshop 2021: /Applications/Adobe Photoshop 2021/Plug-ins
Photoshop 2020: /Applications/Adobe Photoshop 2020/Plug-ins
etc.

Step 9

Open Photoshop. "Topaz Gigapixel AI" should now show up under File -> Automate.


Manually Install Gigapixel AI As A Photoshop Plugin On Windows

Step 1:

Close Photoshop

Step 2:

Open File Explorer and navigate to your Gigapixel AI installation directory. This is typically found in the following folder:

C:\Program Files\Topaz Labs LLC\Topaz Gigapixel AI

Step 3:

Right click the PS_Plugins_x64 folder and select "Send to -> Desktop (create shortcut)".

Step 4:

Navigate to your desktop and rename the created shortcut to tltopazgigapixelaips_x64.

Step 5:

Right click and copy the tltopazgigapixelaips_x64 folder.

Step 6:

Paste the copied folder in the Photoshop plugins location for your Photoshop installation.

To do this, open File Explorer and navigate to your appropriate Photoshop plugins folder. It will either be for Photoshop CC or the version-specific folders (Photoshop 2020, Photoshop 2021, etc).

Photoshop CC (Shared Creative Cloud Location): C:\Program Files\Common Files\Adobe\Plug-ins\CC\

OR

Photoshop 2021 (Version Specific): C:\Program Files\Adobe\Adobe Photoshop 2021\Plug-ins\
Photoshop 2020 (Version Specific): C:\Program Files\Adobe\Adobe Photoshop 2020\Plug-ins\
etc

Note About Photoshop Versions After 2018
For Photoshop 2018 and higher, you may have both the version-specific and shared creative cloud folders on your computer. In these cases, you may need to try to install the plugin shortcuts to both folders if you're not sure which version of Photoshop you're actually opening on your computer.

If you have other Topaz products installed, it should look something like this:

Step 7:

Paste the tltopazgigapixelaips_x64 shortcut into this folder.

Step 8:

Open Photoshop, and verify that "Topaz Gigapixel AI" shows up under File -> Automate.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us