Topaz Glow works as both a standalone editor and plugin. This means that a compatible host editor is not required to use Topaz Glow. Although, you may access it as a plugin via compatible host editors.

System Requirements:

Mac OS X 10.8+

Windows 7+ x64, OpenGL 2.1

 

Download Instructions:

  • To download Glow, please visit www.topazlabs.com/downloads
  • Locate Topaz Glow and click on the appropriate Mac or Windows button beneath that product to start your download.
  • The download you start automatically, however, if prompted, select "Save".
  • The downloaded installer will be located in your Downloads folder or Desktop, most likely, as an .exe (Win) or .dmg (Mac)

The program will then install as a standalone editor to:

Mac: HD/Applications

Win: C:\Program Files\Topaz Labs\Topaz Glow

Plugin Compatibility:

To use Topaz Glow as a plugin, first run the standalone program via the directories listed above.  This is a one-time setup that require to use the software as a plugin.

Glow can then be accessed as a plugin via:

  • Photoshop CS4+
  • Photoshop Creative Cloud
  • Photoshop Elements 6+
  • Corel Paintshop Pro X
  • Lightroom, via external editor
  • Not compatible with PhotoFXLab or Fusion Express

Accessing Glow in PS, PS CC, and PSE:

After launching Glow as a standalone editor, it will become available in your Photoshop Filter menu (you may need to restart Photoshop). 

If not, please see here on how to access it there:

I can't find Glow in the Photoshop Filter menu

Important: Your image will need to be 8 or 16-bit depth in RGB color mode. You can change this via ImageMode in Photoshop.

Accessing Glow in Lightroom: 

Topaz Glow can be accessed as an external editor in Lightroom by going to Photo > Edit In > Topaz Glow.

Important: For optimal use of Glow, go to Lightroom > Preferences > External Editing.

Make sure that "TIFF" is selected under File Format. In addition, select 16bits/component for bit depth. For color space, use AdobeRGB(1998) for optimal editing. 

Accessing Glow in Corel PaintShop Pro X:

To configure Glow as a plugin in PaintShop Pro:

  1. Go to File-> Preferences-> File Locations...
  2. Scroll to select ‘Plugins from the File types list and click ‘Add’
  3. Navigate to C:\Program Files\Topaz Labs\Topaz Glow. Select the Topaz Glow folder and click OK. 
  4. Click OK again to return back to your main screen.
  5. Go to Effects-> Plugins-> Topaz Labs-> Topaz Glow and select it to start the program. 

Accessing Glow in Serif Photo Plus: 

  1. Go to File > Preferences
  2. Select Plug-ins from the list and then click Browse.
  3. Navigate to: C:\Program Files\Topaz Labs
  4. Select the Topaz Labs folder and press OK.
  5. Press OK again to return back to your main screen.
  6. Exit out of Serif and then re-open it.
  7. To access Glow, open an image and go to Effects > Plugin Filters > Topaz Labs > Topaz Glow

Entering your License Key

Upon entering Glow, you should be prompted to enter your 30-digit license key. Simply copy & paste this license key into the provided space to activate the program or start your trial.

If you're on a trial, please know that there is no difference between the trial and purchased software versions.  The only difference is the license key used to activate the program.  This means that you do not need to re download the software if you already have the trial installed and have made your purchase.

Important:  You can use your purchased software on two computers at a time. The key will work for both Mac and PC.  Navigate to www.topazlabs.com/downloads to download the appropriate software.

 

Have more questions? Submit a request



Can't find what you're looking for?